
 Online Library Help
 

Interface Description 
There are two ways to view the content of the codes – using either the “Frames” or “No Frames” interface. 
We recommend using the “Frames” version for most users. The “No Frames” version is recommended for 
Netscape users and for those with slower Internet connections. 
 
Using the “Frames” Interface 
This interface is made up of three frames, or areas on the screen, where different information is 
displayed. Each is identified and described below: 

  

 
 

1. Document Frame 
This is the frame that displays the content of the Code of Ordinances. In general, the document frame will 
display one entire code chapter at a time, though some codes are displayed by section. You can scroll 
through the sections of the chapter or click on any hyperlinks that appear in the text of the code.  
  
By clicking on the appropriate tab within the document frame, you can choose to view the document, your 
search results, a split screen of the Document and your search results or the Advanced Search form: 

  

 
  

2. Table of Contents Frame 
This frame displays the table of contents for the Code of Ordinances.  In general, the table of contents will 
display the various headings, subheadings, and sections of the code.  Please note that because each 
code is different, there is no single structure for the table of contents. 
 



To make sure that you can access the table of contents no matter which browser you are using, there are 
two ways to view it – using the JAVA tab (which uses java to display the table of contents) or using the 
HTML tab (which uses html to display the table of contents). For more specific information about the table 
of contents, see “Using the Table of Contents”. You can resize the table of contents by dragging the bar 
between the table of contents and the document window. This will let you see as much, or as little, of the 
table of contents as you need. 
 
3. Search and Navigation Frame 
The frame along the top edge of the screen is used to navigate and search the code.  It gives easy 
access to all the site’s search features and navigation controls, such as: 

  

 

Use the Quick Search located on the top left-hand side of the screen for 
simple searches. 
  

 

For more searching options, choose one of the easy-to-use search forms 
from the Advanced Search menu on the toolbar. 
  

 

The Tools menu lets you easily print and download text from the codes. 
You can even set bookmarks within the codes to make information easier 
to access in the future. 
  

 

Use the Links menu to easily view other areas of the site or to contact 
American Legal Publishing’s technical support staff.  
  

  
Use the "Next Chapter" and "Previous Chapter" (or "Next Section" and "Previous Section") buttons to 
browse the code or click on "Sync Contents" to synchronize the Table of Contents with your location in 
the code to make it easier to find related information. Use the “Start Over” button to reset the website and 
start over from the code’s home page. 

 
Using the “No Frames” Interface 
This option is recommended for Netscape users and for users with slower Internet connections. This 
interface works in the same way as the “Frames” interface but is simplified to display all code information 
within a single frame in the browser. The simplified design puts all navigation and searching on the left 
side of the screen. 
 

 



Searching the code(s) 
 
What are the different ways to search the code? 

 

 

Use the Quick Search located on the top left-hand side of the 
screen for simple searches. This works best for single word 
searches, such as names, section numbers, etc. 
 

 

For more searching options, choose one of the easy-to-use search 
forms from the Advanced Search menu on the toolbar. 
 

  • Choose the “Boolean Search Form” if you are familiar with the 
Boolean searching syntax.  

  • Choose the “Advanced Search Form” to easily search for 
exact phrases, synonyms, and more. You can also use this 
search form to narrow your search to specific portions of the 
code by using the checkboxes that appear in the Table of 
Contents frame.  

  
The “Advanced Search Form” and “Boolean Search Form” also let you apply searches to ALL the codes 
in any state. This can help you find similar provisions in other municipalities or find model provisions. To 
use this feature, open either search form, type in your search terms and then use the drop-down menu to 
choose how to apply your search: 
 

 

Use this option to simply search the code that you are viewing in 
the table of contents. 
  

 

Choose a state from this list to apply your search to all the codes in 
our Online Library in a particular state. In this example, the search 
will be applied to all codes in the state of Florida. 
  

 
Understanding Your Search Results 
The results of any search will appear in the document frame under the “Results” tab. Click on any of the 
search results to view the text of that "hit" or “match” in the document frame.  
  
  

 
  
  



You can also choose to view your search results and the code text simultaneously by choosing the 
“Doc/Results” tab: 
  

 
  
Use either the “Prev Match” and “Next Match” buttons to scroll through your search results within a 
chapter or click on another search hit from the results list. Choose the “Clear Search” button to clear your 
active search and reset the search form. 

 
Your search results are also reported in the table of contents as orange numbers next to the title, chapter 
or section headings. This may help you quickly identify which search “hits” or “matches” are most likely to 
be useful. You can use the table of contents to go directly to a specific result by clicking on the 
appropriate chapter. 

 

 
  



Saving your searches 
Do you ever find that you often search for the same terms over and over again? If so, you’ll be pleased to 
know that you can save your often-used searches.  Once you perform a search, you can save it so the 
search results are easy to access again in the future. Here’s how to save and manage your searches: 
  
At the bottom of your search results list, simply name your search in the following box: 

  

 
  

Once you save your search, you’ll always be able to access it from either search form. If you ever want to 
rename or delete a search, simply choose the “Manage Saved Searches” feature from any search form or 
search results list and make the appropriate changes. 

 

Using the Table of Contents 
Use the Table of Contents in the left frame to find the Title, Chapter or Section that you wish to view.  
  
To make sure that users can access the table of contents no matter which browser is used, there are two 
ways to view it – using the JAVA tab (which uses java to display the table of contents) or using the HTML 
tab (which uses html to display the table of contents). They both display the same information, but in a 
different way. Here’s a sample of each: 

  
 

Using the JAVA table of contents, you can use 
the plus (+) and minus (-) signs next to the folder 
icons to expand and collapse the table contents 
and find the information you need. 

 Using the HTML table of contents, you can click 
on the folder icons to expand and collapse the 
table of contents and find the information you 
need. 

  
Special note for Mac users.  
This site supports the following Mac browsers: Mozilla Firefox v. 1.07 and Safari v. 2.03 (both tested on 
Mac OS 10.4.6). However, our server software is not 100% compatible with other Mac browsers and can 
result in some errors. In testing, we have found that Mac users using Internet Explorer have no problems 
using the site if they turn off the javascript function in their browser settings and use the HTML tab of the 
table of contents (rather than the JAVA tab). If that fails, please email our technical support staff 
(techsupport@amlegal.com). Let us know the city code you are trying to access and which 
chapter/section numbers or topics you are interested in and we will have our staff provide those 
documents to you in a usable format via email (usually as a text file). 
 

mailto:techsupport@amlegal.com


Printing information from the site 
American Legal Publishing’s Online Library gives you more printing options than ever before.  
 

1. Print a selection of text by highlighting the appropriate text in the document frame and 
using your web browser’s print function. After highlighting the text you wish to print, either 
select "Print" from the "File" Menu or press "CTRL+P to access the Print Dialog Box. 
Under "Print Range", choose "Selection" and the highlighted text will print. 

 

 
  

OR  
  
2. If the code is displayed by chapter, you can print an entire chapter by selecting the 

“Print this Chapter” feature from the Tools menu or using your browser's "Print" button. 
Important Note: Be aware that some chapters can be quite large so before printing an 
entire chapter, we suggest using your browser’s “Print Preview…” feature on the “File” 
Menu to make sure that you are printing exactly what you want. 

  
3. If the code is displayed by section, you will be limited to printing individual sections 

from the code. Use the “Print this Section” feature from the Tools menu or your browser's 
"Print" button. 

 

Using the “bookmark” feature 
The Online Library allows you bookmark information within an online code to make information easier to 
access again in the future.  
  
Here’s how to set a bookmark within a code: 
  

 
  

• Using Microsoft Internet Explorer.  Simply choose the “Bookmark This Chapter” or “Bookmark 
This Section” feature from the Tools menu on the top of the screen, and the bookmark will be 
added to IE’s “Favorites” list for you to access in the future.  

  
• Using Netscape.  Netscape doesn’t support the automatic adding of bookmarks, so choose the 

“Bookmark This Chapter” or “Bookmark This Section” feature from the Tools menu on the top of 
the screen. When the new browser window opens, manually press CTL+D (shortcut key for 
bookmarking) on that page and the bookmark will be set.  

  



Downloading files from the site 
You can download text from the codes in our Online Library. You even have a choice of 3 file formats -- 
.html, .rtf, or .txt!   
 
To download text, simply follow these steps: 
 
1. Choose the “Download This 
Chapter” or “Download This Section” 
feature from the Tools menu on the top 
of the screen. 
 

 

2. Make your file format selection and 
click “Download”. 

 
 

3. Choose “Save this file to disk”, click 
“OK”. 

 
 

4. Specify name and location for the 
file on your computer 

 
 



Troubleshooting Tips 
  

1. Check your browser's privacy settings (under Tools, Internet Options in the IE browser). 
Our web site requires the use of certain session-based cookies to function properly. If your 
privacy level is set too high, your browser will not accept cookies and our site cannot function 
correctly. The site will work when your browser's privacy setting is set anywhere from "Low" to 
"Medium High", but it will NOT work if set to "High" or above. 

 
2. Clear out your computer's temporary memory. Clear out your computer's temporary memory. 

Old cached files can occasionally cause problems when accessing the web site. We recommend 
that you regularly clear out your temporary internet files and your cookies. Here are instructions 
for doing this in Internet Explorer 6.0: (1) Open the "Internet Options" from your browser's "Tools" 
menu. (2) Delete the "Cookies" and the "Temporary Internet Files" using the buttons. (3) Close 
and re-open your browser to try to access the web site again. 

 
3. Make sure your browser is up-to-date. The codes and other documents available on this site 

are best viewed using the following Windows browsers: Internet Explorer 6.0, Internet Explorer 
5.5, Netscape 7.1, Netscape 6.2.3, and Firefox. The web site also requires that java and cookie 
support are enabled on your browser. In order to view and search the codes most effectively, the 
site also requires that cookies, java and javascript are installed and enabled on your browser. 

 
4. Are you a Mac user? This site supports the following Mac browsers: Mozilla Firefox v. 1.07 and 

Safari v. 2.03 (both tested on Mac OS 10.4.6). However, our server software is not 100% 
compatible with other Mac browsers and can result in some errors. In testing, we have found that 
Mac users using Internet Explorer have no problems using the site if they turn off the javascript 
function in their browser settings and use the HTML tab of the table of contents (rather than the 
JAVA tab). If that fails, please email our technical support staff (techsupport@amlegal.com) and 
let us know the code you are trying to access and which chapter/section numbers or topics you 
are interested in. We will have our staff provide those documents to you in a usable format via 
email (usually as a text file). 

 
If you have further questions about this site, please contact American Legal Publishing’s technical support 
staff by email (techsupport@amlegal.com) or call 1-800-445-5588. 
 
Please keep in mind that American Legal Publishing Corporation is a legal publishing company. The 
purpose of our technical support staff is to answer questions related to the operation of our web site. We 
are not qualified to perform research or answer questions dealing with the content of a particular 
municipality’s code. If you have questions about a code’s content, please contact the appropriate 
municipality directly for that information. 
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